RDP remote desktop copy and paste clipboard stopped working

I'm developing remotely by using a VPN and Remote Desktop / Terminal Services to connect to my development environment insde a client's network. Nothing unusual there. The really frustrating thing is when trying to copy and paste some code snippets between local and remote desktops and I get some old nonsense from the destination machine's clipboard instead of the code I was expecting from the source clipboard.

Yes I have already ticked to share the Clipboard when starting the session, but copy and paste is still broken, even though it worked before on the same two machines. In the past when this happened I would hope that disconnecting and reconnecting the RDP session would be enough to get the clipboard behaving again. If that didn't work then I'd log off the remote machine and start a new session and that would usually do the trick, but the need would be accompanied by a few choice expletives if it meant having to waste time re-opening several apps again.

A search saw various complicated solutions to this sporadic issue, including scripts to re-register windows with clipboard events and such things that I do not understand enough to trust. Then I saw this extremely simple solution, which worked quickly and perfectly for me:


In short:

- run taskmgr.exe
- find and kill rdpclip.exe process
- run rdpclip.exe

Job done!

There are no comments yet...Kick things off by filling out the form below.

Leave a Comment

Leave this field empty: